目 录CONTENT

文章目录

apt-get udate报错public key is not available

xlong
2024-04-14 / 0 评论 / 0 点赞 / 8 阅读 / 678 字 / 正在检测是否收录...

apt-get udate报错public key is not available

ubuntu21.10和fedora35开始使用glibc2.34甚至更高的版本。在glibc2.34版本里面,开始使用一个名为clone3的系统调用。通常情况下,容器里面所有的系统调用都会被docker捕获,然后docker决定如何处理它们。如果docker中没有为特定系统调用指定策略,则默认的策略会通知容器这边"Permission Denied"。但是,如果 Glibc 收到此错误,它不会回退。它仅在收到响应“此系统调用不可用”时才执行此操作。

解决方法:

将docker升级到20.10.14以上的版本(> =20.10.14)

0

评论区